Go Back   Cyber Tech Help Support Forums > Software > Internet / Browsers

Notices

Reply
 
Topic Tools
  #1  
Old April 5th, 2017, 07:51 PM
Total Noob Total Noob is offline
Senior Member
 
Join Date: Sep 2007
Posts: 419
Firefox won't clear history

Firefox 52.0.2 on a Win 7 Pro, SE1, no brand computer with Athlon 64 x2 dual core 6000+ processor.

Inexplicably, Firefox won't clear history when I turn off the browser, even though that is the setting. It also has no OK button when going to the "clear history" tab. Everything I want removed is checked, but there is no place to execute that instruction.

Any thoughts? Thanks.
Reply With Quote


  #2  
Old April 5th, 2017, 10:31 PM
Jintan's Avatar
Jintan Jintan is offline
Malware Removal Team Advisor
 
Join Date: Dec 2004
Posts: 51,626
Hi Tote.

The Clear Now button doesn't show?



Why not try to Reset Firefox, and see if that corrects things.
Reply With Quote
  #3  
Old April 5th, 2017, 10:32 PM
Jintan's Avatar
Jintan Jintan is offline
Malware Removal Team Advisor
 
Join Date: Dec 2004
Posts: 51,626
Very strange on that reply the way it mixed things together. Can you make out what I meant by doing the Reset?
Reply With Quote
  #4  
Old April 6th, 2017, 03:43 PM
Total Noob Total Noob is offline
Senior Member
 
Join Date: Sep 2007
Posts: 419
Quote:
Originally Posted by Jintan View Post
Hi Tote.

The Clear Now button doesn't show?



Why not try to Reset Firefox, and see if that corrects things.
No "Clear Now" button appeared either before or after a refresh. I don't understand it. Also, though I set Firefox initially to "Never Remember History" it always does, and it takes a full Ccleaning to delete this crap.

Any ideas?
Reply With Quote
  #5  
Old April 7th, 2017, 07:10 AM
Ned Seagoon Ned Seagoon is offline
Senior Member
 
Join Date: Jun 2004
O/S: Windows 10 Home
Location: Sunshine Coast, Australia
Age: 74
Posts: 2,848
Change the Option to "Remember History" then after restarting the browser clear the history, then change it back to "Never Remember History"

Worked for me.
Reply With Quote
  #6  
Old April 12th, 2017, 09:11 PM
Total Noob Total Noob is offline
Senior Member
 
Join Date: Sep 2007
Posts: 419
Quote:
Originally Posted by Ned Seagoon View Post
Change the Option to "Remember History" then after restarting the browser clear the history, then change it back to "Never Remember History"

Worked for me.
Unfortunately, I can't get there from here. I can't clear the browser history first because the drop down menu doesn't have a "clear browser" button. See above. I tried toggling "remember history" as you recommend, but did not have any luck with it.
Reply With Quote
  #7  
Old April 14th, 2017, 05:02 PM
Appzalien Appzalien is offline
Senior Member
 
Join Date: Sep 2010
Posts: 488
You don't necessarily need a clear history button to do this. This is what I did. Open the History tab and select "Show all History" In each section (Last 7, this month and the Months name) start highlighting whats in each separate window and right click "Delete". It will take some time but once they're all gone and you have the proper settings for history selected nothing will come back. All my sections are still empty and I did this weeks ago. Like under the Tools > Options menu for Privacy settings make sure you choose the custom settings for history and uncheck "Remember my browsing and download history" "Remember search and form history". Unchecking these two will in effect grey out the "Clear history when Firefox closes" check box since there will be nothing there to clear any more.
Reply With Quote
Reply

Bookmarks

Topic Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump




All times are GMT +1. The time now is 12:41 AM.