Go Back   Cyber Tech Help Support Forums > Hardware > Hardware

Notices

Reply
 
Topic Tools
  #1  
Old August 6th, 2008, 04:37 PM
PaddyM PaddyM is offline
New Member
 
Join Date: Jun 2008
O/S: Windows 7 64-bit
Location: Northern Ireland
Posts: 24
USB External Hard Drive "Write Protected" Issues

Dear awesome IT experts,

For the past couple of weeks my Western Digital Elements 500GB USB drive intermittently sets itself to "write protected" for no apparent reason. Rebooting would normally solve the problem for a day or two, but today I've tried rebooting several times, and once into Safe Mode, and the drive remained set to "write protected" regardless. I've also tried simply unplugging the power cable and then plugging it back in, which didn't work either. On top of that, Western Digital have a "spindown" utility that powers down the drive for safe removal; I used this, and then switched it back on again, but the problem remained. However, the spindown utility usually doesn't work at all when the drive is in this state, so I'm not sure why it worked this time.

When the drive is in this irritating state, saving files, creating new files, changing security/sharing permissions and running scans on the drive are all impossible; I just get "media is write protected" or "drive is write protected" errors.

I ran an entire surface scan (using Western Digital's own LifeGuard diagnostic tool) and no errors were found. Obviously this was done prior to the problem becoming seemingly permanent.

There is no "write protection" switch, button or slider on the drive that I can see, and the drive hasn't moved from its current position in months so even if it had such a switch I can't image how it would have been activated.

I'm using Windows Vista Ultimate SP1 x64, and I'm the administrator (I'm the only user, actually). I've been using Vista for a few months now and the problem only started a couple of weeks ago, so I'm reasonably sure it's not a "user rights" issue or the like.

My system specs are as follows (they've remained the same since November 2007 except for my RAM, which I upgraded to 2 x 2GB sticks from 2 x 1GB sticks; this occurred about 3 weeks ago):

CPU: Intel Q6600 Core 2 Quad 2.40 GHz
GPU: nVidia GeForce 8800GTX 768MB (Gainward)
Motherboard: ASUS Striker Extreme Motherboard
RAM: 4GB Corsair XMS2 800MHz
PSU: OCZ Technology PC Power & Cooling 750W Silencer Quad

I'm not sure what else will be relevant to the problem, so I'll stop here!

Thanks for reading!
Reply With Quote


  #2  
Old August 7th, 2008, 10:47 AM
PaddyM PaddyM is offline
New Member
 
Join Date: Jun 2008
O/S: Windows 7 64-bit
Location: Northern Ireland
Posts: 24
I followed the instructions given on this webpage for altering a registry value that will unlock storage devices, and it has worked (for now). However, this is only half the problem; the other half is the fact that my drive randomly sets itself to "write protected" at all.

Cheers!

Last edited by PaddyM; August 7th, 2008 at 07:57 PM.
Reply With Quote
  #3  
Old August 7th, 2008, 05:28 PM
Murf's Avatar
Murf Murf is offline
Moderator
 
Join Date: Oct 2001
O/S: Windows 7 64-bit
Location: Newport News VA
Posts: 15,719
Try this:

Start | All Programs | Accessories | Command Prompt

At the flashing cursor type the following:

diskpart (hit <enter>)

Now select the external disk

Now type the following

Attributes volume clear readonly (hit <enter>)

Exit

Did this help????
Reply With Quote
  #4  
Old August 7th, 2008, 08:10 PM
PaddyM PaddyM is offline
New Member
 
Join Date: Jun 2008
O/S: Windows 7 64-bit
Location: Northern Ireland
Posts: 24
Thanks for the reply!

I tried what you said, but when I type "Attributes volume clear readonly" and press enter I get this error:

Code:
There is no volume selected.
Please select a volume and try again.
I tried typing E: Attributes volume clear readonly (E: is the drive in question) and it didn't seem to work; I just get a list of commands seemingly related to the use of diskpart. The same thing happens if I just type E: on its own. However, if I type Attributes volume clear readonly E: I get this error instead:

Code:
The arguments specified for this command are not valid.
For more information on the command type: HELP ATTRIBUTES VOLUME
What am I doing wrong?

Even if this worked, would it just be a temporary fix like the registry edit I mentioned in my last post (i.e. would I have to do it each time my drive becomes "write protected"?) or would it solve the problem permanently? If it's the former, the registry edit seems easier haha (well, the Thumbscrew tool from the link in my last post makes it even easier still). My goal is to stop this happening in the first place.

Thanks for your time, Murf!
Reply With Quote
  #5  
Old August 8th, 2008, 08:07 AM
liondad's Avatar
liondad liondad is offline
Senior Member
 
Join Date: Nov 2005
O/S: Windows XP Pro
Location: SURREY /UK
Age: 68
Posts: 2,048
Just a note,

Try this program, [FREEWEAR]
ERASER,

http://www.heidi.ie/node/6

Not the easyest program to work with.
BUT VERY GOOD,

Use it to wipe the files first,
then format the the harddrive,

As i say its not the easyest of programs,
GUI is very plain
but there are help files,
but its good for stubborn harddrives,
that are write proteced and the files refuse to delete,
Reply With Quote
  #6  
Old August 8th, 2008, 11:28 AM
PaddyM PaddyM is offline
New Member
 
Join Date: Jun 2008
O/S: Windows 7 64-bit
Location: Northern Ireland
Posts: 24
Quote:
Originally Posted by liondad View Post
Just a note,

Try this program, [FREEWEAR]
ERASER

...

As i say its not the easyest of programs,
GUI is very plain
but there are help files,
but its good for stubborn harddrives,
that are write proteced and the files refuse to delete,
Thanks for the reply!

Unfortunately, I'm not seeking to wipe my hard drive, I just want to be able to delete files at will and edit other files, etc. But again, even if this software worked, it still wouldn't help me understand why the write protection gets activated randomly at all, which is the main problem.

Thanks for the software, though. I'll definitely keep this one handy should I need to wipe a hard drive (which I probably will at some point).

Cheers!!
Reply With Quote
  #7  
Old August 26th, 2008, 01:35 PM
PaddyM PaddyM is offline
New Member
 
Join Date: Jun 2008
O/S: Windows 7 64-bit
Location: Northern Ireland
Posts: 24
I think I've found a workaround for this problem. I say "workaround" because it basically involves changing a few things from their default settings, which doesn't really solve the problem so much as bypasses it.

Firstly, I found a series of options in the Group Policy Object Editor that deal with read/write permissions on hard drives and removable media. I basically changed their individual settings from "Not configured" to "Disabled". They are as follows:

Start > Run... > gpedit.msc > OK

Computer Configuration > Administrative Templates > System > Removable Storage Access [In here I disabled all of the "Deny read access/write access" options; you may only want to disable the ones relating directly to your type of media]

Do the same as above, except the first step is "User Configuration" instead of "Computer Configuration"

The second thing I did involves the registry. Backup your registry before continuing. If you're not sure how, read on.

Start > Run... > regedit > OK

Highlight "Computer" and right-click. Select "Export" and save the backup somewhere safe. Just double-click it if you want to reset the changes you make.

Navigate to the following registry location:

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Contro l\StorageDevicePolicies

Click on StorageDevicePolicies and on the right-hand side there should be a DWORD value labelled "WriteProtect". If there isn't one, create it. Either way, make sure it has a value of 0. Double-click it to change it.

Do the same with the following two locations (creating any non-existent keys/values along the way):

HKEY_LOCAL_MACHINE\SYSTEM\ControlSet001\Control
HKEY_LOCAL_MACHINE\SYSTEM\ControlSet002\Control


I haven't had the problem since I did this, which was the same day as my last post (about a week) so I'm reasonably confident that this has put a stop to it. I hope so, anyway!

Thanks!
Reply With Quote
  #8  
Old February 26th, 2009, 05:04 PM
olala olala is offline
New Member
 
Join Date: Feb 2009
Posts: 2
I am trying to remove READ ONLY protection on a truecrypt hidden system encryption. Anyway. I am not able to find the - Computer Configuration > Administrative Templates > System > Removable Storage Access Folder in gpedit.msc

Is it because I have a newer version of Windows than PaddyM? I have Windows SP3 with all the updates.

Thanks for any replys
Reply With Quote
  #9  
Old February 26th, 2009, 06:53 PM
PaddyM PaddyM is offline
New Member
 
Join Date: Jun 2008
O/S: Windows 7 64-bit
Location: Northern Ireland
Posts: 24
Quote:
Originally Posted by olala View Post
I am trying to remove READ ONLY protection on a truecrypt hidden system encryption. Anyway. I am not able to find the - Computer Configuration > Administrative Templates > System > Removable Storage Access Folder in gpedit.msc

Is it because I have a newer version of Windows than PaddyM? I have Windows SP3 with all the updates.

Thanks for any replys
If you are using XP I think the only edition which allows access to gpedit.msc is "Professional". However, I've found since I made my last post that the method I outlined - including the registry editing - doesn't actually work (or at least doesn't work very well). I still get the write protected problem every other time I reboot my system. There seems to be no logic/consistency to it.

With regards to your drive, olala, when you are logged in to Windows try unplugging the cable which connects the drive to the PC and then plug it back in. Windows will "find" the drive again and hopefully this time it will be unprotected. This is what I do, and it usually works. It's not ideal, but there's no other way around it as far as I can see

I contacted Western Digital about my drive and they said Vista x64 isn't supported by their hardware or indeed their technical support department. Useless wankers.
Reply With Quote
  #10  
Old February 26th, 2009, 07:24 PM
olala olala is offline
New Member
 
Join Date: Feb 2009
Posts: 2
Thank you for your reply.
The only problem tho, is that it's the system drive I am trying to remove the READ ONLY protection from. Is there anyway I can remove the READ ONLY protection at boot?
Reply With Quote
  #11  
Old February 27th, 2009, 02:33 PM
PaddyM PaddyM is offline
New Member
 
Join Date: Jun 2008
O/S: Windows 7 64-bit
Location: Northern Ireland
Posts: 24
Quote:
Originally Posted by olala View Post
Thank you for your reply.
The only problem tho, is that it's the system drive I am trying to remove the READ ONLY protection from. Is there anyway I can remove the READ ONLY protection at boot?
Ahhh I see. That is a problem haha. I'm not sure how to get around that, but have you examined the drive itself to see if there is a switch or button which activates/deactivates the write protection? Many drives have this feature (mine doesn't, unfortunately!) and hopefully your does too.
Reply With Quote
  #12  
Old June 22nd, 2009, 07:34 PM
Suzan Suzan is offline
New Member
 
Join Date: Jun 2009
Posts: 1
Where to find USB with external switch?

According to this post you can find external USBs with switches on the outside to make them write protected. Where/what brand has this feature?
thanks!
Reply With Quote
  #13  
Old January 18th, 2010, 02:20 AM
drpoddar drpoddar is offline
New Member
 
Join Date: Jan 2010
Posts: 1
Hey try this ...this worked well for me...

> go to control panel
>open administrative tools
>select and open computer management
>Under the "Storage" option you will find "Removable storage"
>Right click 'removable storage' and select properties
>You will find a security tab...add yourself and give full read, write & modify permissions..
save and exit. and then copy paste or make changes to the removable storage and it will work.....This worked for me and also on windows XP..
Reply With Quote
  #14  
Old October 17th, 2010, 02:46 PM
Retrograde Retrograde is offline
New Member
 
Join Date: Oct 2010
O/S: Windows 7 64-bit
Location: Troutman, NC
Posts: 2
I had a similar problem including the same frustrating intermittancy with my terrabyte WD USB-interfaced 'My Book' external hard drive. My incremental back-up program (Roxio Retrospect V7.7) often left the hard-drive irreversibly 'write-protected' after completing a routine incremental back up. Every time I tryed to remove this protection by deselecting the option button in the appropriate 'Properties' menu I received an error notice which left the selection unchanged. The only reliable work-around I was able to come up with was to reformat the drive lossing my entire back-up set in the process.

Then I tried the following which seems to work for me (at least it hasn't failed yet:
1) Using a similar approach as described in the preceding response by drpoddar, find your way through the following hierarchy:
Control Panel>System and Security>Computer Management>Device Manager
2) Select your specific problem media from the list
3) Right-click Policies
4) Select the Better Performance option instead of the default

This simple change in selection eliminates the error message that irreversibly locked me into the write protect mode in the original Properties menu.

Hope this helps...
Reply With Quote
  #15  
Old October 19th, 2010, 04:58 AM
Retrograde Retrograde is offline
New Member
 
Join Date: Oct 2010
O/S: Windows 7 64-bit
Location: Troutman, NC
Posts: 2
Opps! Well the latest work-around I cited earlier no longer works. This behavior is most perplexing in that apparent remedies, such as disconnecting the USP drive and then reconnecting it to force it to be re-recognized by the operating system, or changing the assignment parameters as described in my earlier post seemed to work for a while and now no longer function. It's almost as if a virus is at work whose sole function is to reset 'write protect' on my external USB drive no matter how it is configured within Windows. Indeed, as a last resort, I used to be able to turn off write-protection by reformatting the drive. Now when I try this method I find that even this approach is blocked. I now get an error message indicating that the disk is write protected and hence, cannot be formatted! The only way I was able to get around this impasse' was to disable the write-protection option inside the registry using a method similar to others as described earlier in this thread. This strategy has allowed me to do a complete (slow) reformat which I hope will solve the problem. We shall see...
Reply With Quote
Reply

Bookmarks

Topic Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump




All times are GMT +1. The time now is 03:20 PM.