Go Back   Cyber Tech Help Support Forums > Software > Gaming

Notices

Reply
 
Topic Tools
  #61  
Old February 2nd, 2007, 08:18 AM
ipfree549's Avatar
ipfree549 ipfree549 is offline
Member
 
Join Date: Jan 2007
O/S: Windows XP Pro
Location: Alberta Canada
Age: 27
Posts: 45
WORM, are you using X-Fire, cause when i was playing the F.E.A.R demo, that almost scared the **** from me, i noticed that with xfire on i only got 14 FPS When i closed it i got around 70 FPS close it and try again, also
Close all unused programs in the task manager or system tray
Reply With Quote


  #62  
Old February 4th, 2007, 08:45 AM
lazygeneration0's Avatar
lazygeneration0 lazygeneration0 is offline
Senior Member
 
Join Date: Sep 2006
O/S: Windows Vista 64-bit
Posts: 164
Its more than likely a lack of voltage being supplied to your GFX card because of a cheap ass PSU. (which has already been stated) I would definately recommend getting a PSU of higher and better quality. OCZ has a 600W GameXstream PSU that is really nice (currently using) and it was only $120 when I bought it.

Which reminds me, why the hell havent they sent me my rebates yet??? Same with BFG??? Wonder how long its been since I sent it in.
Reply With Quote
Reply

Bookmarks

Topic Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump




All times are GMT +1. The time now is 08:03 PM.