Go Back   Cyber Tech Help Support Forums > Operating Systems > Windows 10

Notices

Reply
 
Topic Tools
  #1  
Old September 25th, 2018, 08:24 PM
leachim leachim is offline
Senior Member
 
Join Date: Apr 2006
O/S: Windows 10 Home
Location: UK
Posts: 858
Advent X700 Sound Drivers

I have this laptop with Win 10 and the sound has gone - tried all sorts of installing and uninstalling

Not sure if it didn't happen after an update. I have version 1803.

The Advent website doesn't exist for downloads

Any advice ?

Thanks
Reply With Quote


  #2  
Old September 25th, 2018, 11:06 PM
IPR512's Avatar
IPR512 IPR512 is offline
Jill
 
Join Date: May 2006
O/S: Windows 10 Pro
Location: Tampabay area of Florida
Posts: 2,238
I Googled AdventX700 Drivers, and got happy when I saw it brought up a question on another computer forum, but it was from you.
I found this site, but not sure about some of these places, and how safe they are, but you might want to have a look.
https://www.solvusoft.com/en/update/...advent/models/
Reply With Quote
  #3  
Old September 26th, 2018, 12:47 AM
Murf's Avatar
Murf Murf is offline
Moderator
 
Join Date: Oct 2001
O/S: Windows 10 Home
Location: Newport News VA
Age: 73
Posts: 17,064
If it worked before then the driver is probably still on the computer. Try highlighting Sound in Device Manager and do a hardware scan.

Click Start, type in Device Manager then click on result

Should be an entry under Sound, video and game controllers, click on it to open

Look for something with the word Advent, then right click on it scan for hardware changes, NO then same thing but try update driver.
Reply With Quote
Reply

Bookmarks

Topic Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump




All times are GMT +1. The time now is 05:55 PM.