Go Back   Cyber Tech Help Support Forums > Hardware > Networking

Notices

Reply
 
Topic Tools
  #1  
Old November 26th, 2020, 10:20 AM
englandjeff's Avatar
englandjeff englandjeff is offline
New Member
 
Join Date: Oct 2010
O/S: Windows 10 Home
Location: Worcester, England
Posts: 12
Cool Broadband Speed Conundrum

I have a Dell PC, Windows 10 2004 for x64 with Superfast Broadband around 70 mb/s using a brand new BT Smart Hub/Router 2, and a modern BT wired installation from the master socket and out onto the telegraph pole. I have an ethernet hard wire connection between PC and Hub/Router.
I recently checked my broadband speed using my PC and it was recording in the 20s mb/s. It would normally record around 71/72 mb/s. Called BT. They could not see a problem from their end but sent me the Smart Hub as described above to replace an existing quite modern Hub/Router. Still the same result. An engineer came. He had a hand held gadget which showed that the the speed substantially exceeded 70 mb/s (near 80 mb/s) from the Hub/Router so apparently no problem. He showed me the result though I have no idea what is hand held gadget was or how it worked.
BT's own internet speed checker is out of action but, with the PC, I used (with the engineer) a variety of internet speed checkers all coming up with results on my PC in the 20s mb/s. The engineer's personal favourite checker was 'ookla' which showed those same results. I wasn't offered any explanation as to what might cause the apparent difference in the results between use of the PC and his gadget. He had done his job and left.
When the engineer had gone I tried a different ethernet cable but still no difference. I also tried an iPad using a WiFi connection to the Hub/Router which also showed a result in the 20s range.
I have never before had a problem in recording my broadband speed in the 70s via the PC. So why now?
I have to say that my PC performs quite acceptably but I cannot be sure, in my own mind, that I am getting 70 mb/s. Even in the 20s I would expect a fair response. I don't get buffering problems on videos.
Given that the engineer couldn't find a fault has anyone any idea what could cause such a wide discrepancy in the readings? Might it be that some inherent fault has developed during Covid in the BT network which makes it difficult for a PC to accurately read speeds which might resolve when enough folk are back at work? Without any evidence I can't ask BT to do any more than they have done. The fact that BT's own internet checker is out of action makes me wonder if the problem is widespread but temporary and that the explanation is being kept confidential for some reason. That's pure supposition on my part.
Reply With Quote


  #2  
Old November 28th, 2020, 04:18 AM
Ned Seagoon Ned Seagoon is offline
CTH Subscriber
 
Join Date: Jun 2004
O/S: Windows 10 Home
Location: Sunshine Coast, Australia
Age: 77
Posts: 3,173
Could be the ethernet card in your PC, borrow a different PC to repeat the test. Also ensure there are no other unused cables plugged into the Hub/Router to eliminate reflections.
Reply With Quote
  #3  
Old November 29th, 2020, 01:12 PM
englandjeff's Avatar
englandjeff englandjeff is offline
New Member
 
Join Date: Oct 2010
O/S: Windows 10 Home
Location: Worcester, England
Posts: 12
Progress

Hello Ned,
I wasn't in a position to obtain another computer but you got me to thinking about other ways to check the hardware. My PC is from DELL and they have a downloadable 'Support Assist' programme which I have run. It tests and analyses the various components and takes about 15 minutes. That showed all clear.
I don't have any 'loose wires though I did try disconnecting certain peripherals.
However, through perseverance with the Ookla website, I was suddenly offered an Ookla free downloadable "Speedtest for Windows" programme because the Ookla site was reporting connection problems to the server which might be caused by the installed Anti Virus software or some other causes. The programme was also available in a version for Mac computers. It was available in a 64 or 32 bit version so I even got it quite tailor-made for my PC. Running that downloaded programme from the PC I am getting consistent readings around 67 mb/s.
I haven't a clue about exactly what has been happening but that reading is satisfactory. There is clearly some kind of interference involved somewhere.
I should like to thank you for taking the trouble to reply. It doesn't matter that the solution has come from elsewhere. You made me think more deeply, and opened my mind to the fact that there were definitely other rational explanations which might exist for what was happening.
Reply With Quote
  #4  
Old November 30th, 2020, 06:58 AM
Ned Seagoon Ned Seagoon is offline
CTH Subscriber
 
Join Date: Jun 2004
O/S: Windows 10 Home
Location: Sunshine Coast, Australia
Age: 77
Posts: 3,173
A pleasure Jeff, Thanks.
Reply With Quote
Reply

Bookmarks

Topic Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump




All times are GMT +1. The time now is 02:21 PM.